boto3 – Unable to use DynamoDB Global Tables version 2019.11.21

Issue

I am using the current version of boto3.
I was wondering is it possible to create global tables in DynamoDB that are of version 2019.11.21?
According to the boto3 documentation – https://boto3.amazonaws.com/v1/documentation/api/latest/reference/services/dynamodb.html#DynamoDB.Client.create_global_tableThis operation only applies to Version 2017.11.29 of global tables.

Has anyone overcome this in boto3?

Solution

Instead of using the create_global_tables methods – I used the create_table and update_table method after posting a similar question on the boto3 issue board – https://github.com/boto/boto3/discussions/3293#discussioncomment-2901429

Answered By – Damien

This Answer collected from stackoverflow, is licensed under cc by-sa 2.5 , cc by-sa 3.0 and cc by-sa 4.0

Leave a Reply

(*) Required, Your email will not be published