Could not get unknown property 'compile' for object of type org.gradle.api.internal.artifacts.dsl.dependencies.DefaultDependencyHandler

Issue

I was about to add google map activity, and my android studio showed this error

Error:Error:line (25)Could not get unknown property ‘compile’ for object of type org.gradle.api.internal.artifacts.dsl.dependencies.DefaultDependencyHandler.

 <a href="openFi`here`le:C:\Users\dhami\Desktop\uber1\ParseStarterProject\build.gradle"></a>

this is my parse project Gradle file

apply plugin: 'com.android.application'android {                                                                              compileSdkVersion rootProject.ext.compileSdkVersion
buildToolsVersion rootProject.ext.buildToolsVersion

defaultConfig {
    applicationId "com.parse.starter"
    minSdkVersion rootProject.ext.minSdkVersion
    targetSdkVersion rootProject.ext.targetSdkVersion
    versionCode 1
    versionName "1.0"
}

buildTypes {
    release {
        minifyEnabled false
        proguardFiles getDefaultProguardFile('proguard-android.txt'), 'proguard-rules.pro'
    }
}

dependencies {
    compile 'com.android.support:appcompat-v7:23.4.0'
    compile 'com.parse.bolts:bolts-tasks:1.3.0'
    compile 'com.parse:parse-android:1.13.0'
    compile 'com.google.android.gms``:play-services:9.2.1'
}

this is my project gradle file

buildscript {
repositories {
    mavenCentral()
}
dependencies {
    classpath 'com.android.tools.build:gradle:2.1.3'
}}allprojects {
repositories {
    mavenCentral()
}  } ext {
compileSdkVersion = 23
buildToolsVersion = "23.0.1"
minSdkVersion = 14
targetSdkVersion = 23   }

Solution

Just Change your line breaks , it will solve your problem

dependencies {
    compile 'com.android.support:appcompat-v7:23.4.0'
    compile 'com.parse.bolts:bolts-tasks:1.3.0'
    compile 'com.parse:parse-android:1.13.0'
    compile 'com.google.android.gms:play-services:9.2.1'
}

break line after each dependencies.

See answer here : https://stackoverflow.com/a/33991915/4985413

Answered By – Prashant

This Answer collected from stackoverflow, is licensed under cc by-sa 2.5 , cc by-sa 3.0 and cc by-sa 4.0

Leave a Reply

(*) Required, Your email will not be published