Could not load module metadata from

Issue

I am stuck for a day now trying to solve this issue I just updated my android studio but when I open the old project it is showing error

Could not resolve all dependencies for configuration 
':app:debugAndroidTestRuntimeClasspath'.
Could not load module metadata from C:\Users\NEELAY\.gradle\caches\modules- 
2\metadata-2.36\descriptors\com.android.support\multidex- 
instrumentation\1.0.2\5ac5911800d0dfe0ba2d29f224b8c2fb\descriptor.bin
Unexpected metadata type found.

I followed some question also which say to uninstall the android support repository and reinstall but it is not working tried gradle.setting is also proper . Now i have no idea how to solve this issue any help will be helpfull.
Manifest

<?xml version="1.0" encoding="utf-8"?>
<manifest xmlns:android="http://schemas.android.com/apk/res/android"
package="fireapp.manoj.template">
<uses-permission android:name="android.permission.INTERNET" />

<application
    android:allowBackup="true"
    android:icon="@mipmap/ic_launcher"
    android:label="@string/app_name"
    android:roundIcon="@mipmap/ic_launcher_round"
    android:supportsRtl="true"
    android:theme="@style/AppTheme">

</application>

this is the manifest code but dont know why it is showing as setting.gradle
any idea why is it because of the gradle update

Solution

Remove the caches.

Step 1 : Open the terminal

Step 2 : paste cd C:\Users\NEELAY.gradle\ (Navigate to .gradle folder)

Step 3 : rm -r caches\

Step 4 : Now clean or rebuild the project

Answered By – Sriram Subramani

This Answer collected from stackoverflow, is licensed under cc by-sa 2.5 , cc by-sa 3.0 and cc by-sa 4.0

Leave a Reply

(*) Required, Your email will not be published