Docker no basic auth credentials after succesfull login

Issue

I’ve moved to linux (pop_os 21.04) on my desktop and I’m having some issues with docker.
When I’m trying to run docker-compose to pull an image from a private registry I’m getting:

ERROR: Head "https://my.registry/my-image/manifests/latest": no basic auth credentials

Of course before running this command I’ve ran:
docker login https://my.registry.com -u user -p pass
which returns

WARNING! Your password will be stored unencrypted in /home/user/.docker/config.json.
Configure a credential helper to remove this warning. See
https://docs.docker.com/engine/reference/commandline/login/#credentials-store

Login Succeeded

And my config.json in my .docker folder show my credentials

 {
    "auths": {
        "my.registry.com": {
            "auth": "XXXXX"
        }
    }
}

To install docker I’ve followed instructions on their page https://docs.docker.com/engine/install/ubuntu/

And my version is:
Docker version 20.10.8, build 3967b7d

The same command ran on a macos system with Docker version 20.10.8 runs without any issues so I my password and all the urls are correct for sure.

Thanks for any help!

Solution

I reinstalled the whole thing again as the docker page states, didn’t work, so I uninstalled it and proceeded to install snap version, that didn’t work neither and finally I removed it and went with simple apt-get install docker.io and it works like a charm! I don’t know why it didn’t work previously but I won’t lose more sleep over it.

Answered By – user51010

This Answer collected from stackoverflow, is licensed under cc by-sa 2.5 , cc by-sa 3.0 and cc by-sa 4.0

Leave a Reply

(*) Required, Your email will not be published