Failed to resolve: com.google.firebase:firebase-firestore:16.0.1

Issue

I’m switching from realtime database to firestore and I keep getting the same error:

Failed to resolve: com.google.firebase:firebase-firestore:16.0.1

I have looked at similar questions on this site but still haven’t been able to fix this problem.
Here is the code from my app gradle:

apply plugin: 'com.google.gms.google-services'

android {
    compileSdkVersion 28
    defaultConfig {
        applicationId "com.example.marykate.marykatefordefyp"
        minSdkVersion 15
        targetSdkVersion 28
        versionCode 1
        versionName "1.0"
        testInstrumentationRunner "android.support.test.runner.AndroidJUnitRunner"
    }
    buildTypes {
        release {
            minifyEnabled false
            proguardFiles getDefaultProguardFile('proguard-android.txt'), 'proguard-rules.pro'
        }
    }
}

dependencies {
    implementation fileTree(dir: 'libs', include: ['*.jar'])
    implementation 'com.android.support:appcompat-v7:28.0.0'
    implementation 'com.android.support:recyclerview-v7:28.0.0'
    implementation 'com.android.support.constraint:constraint-layout:1.1.3'
    testImplementation 'junit:junit:4.12'
    androidTestImplementation 'com.android.support.test:runner:1.0.2'
    androidTestImplementation 'com.android.support.test.espresso:espresso-core:3.0.2'
    implementation 'com.google.firebase:firebase-core:16.0.1'
    //dependency for using firebase database
    implementation 'com.google.firebase:firebase-database:16.0.1'
    //dependency for email and password authentication
    implementation 'com.google.firebase:firebase-auth:16.0.1'
    //dependency for cloud storage
    implementation 'com.google.firebase:firebase-storage:16.0.1'
    implementation 'com.google.firebase:firebase-auth:16.0.1'
    implementation 'com.google.firebase:firebase-firestore:16.0.1'
} 

and the code from my project gradle is as follows:


    repositories {
        google()
        jcenter()

    }
    dependencies {
        classpath 'com.android.tools.build:gradle:3.2.0'
        classpath 'com.google.gms:google-services:4.0.2'

        // NOTE: Do not place your application dependencies here; they belong
        // in the individual module build.gradle files
    }
}

allprojects {
    repositories {
        google()
        jcenter()
    }
}

task clean(type: Delete) {
    delete rootProject.buildDir
} 

Could anyone help me with this?

Solution

To solve this, please change the following lines of code:

implementation 'com.google.firebase:firebase-core:16.0.1'
//dependency for using firebase database
implementation 'com.google.firebase:firebase-database:16.0.1'
//dependency for email and password authentication
implementation 'com.google.firebase:firebase-auth:16.0.1'
//dependency for cloud storage
implementation 'com.google.firebase:firebase-storage:16.0.1'
implementation 'com.google.firebase:firebase-auth:16.0.1'
implementation 'com.google.firebase:firebase-firestore:16.0.1'

to

implementation 'com.google.firebase:firebase-core:16.0.6'
//dependency for using firebase database
implementation 'com.google.firebase:firebase-database:16.0.6'
//dependency for email and password authentication
implementation 'com.google.firebase:firebase-auth:16.1.0'
//dependency for cloud storage
implementation 'com.google.firebase:firebase-storage:16.0.5'
//implementation 'com.google.firebase:firebase-auth:16.0.1' //Removed
implementation 'com.google.firebase:firebase-firestore:18.0.0

Please don’t also forget to add the as the last line in your file:

apply plugin: 'com.google.gms.google-services'

Answered By – Alex Mamo

This Answer collected from stackoverflow, is licensed under cc by-sa 2.5 , cc by-sa 3.0 and cc by-sa 4.0

Leave a Reply

(*) Required, Your email will not be published