Fatal: git was built without support for git-add–interactive (NO_PERL=1)

Issue

When I do “git add -i” It pops this error:

fatal: git was built without support for git-add–interactive (NO_PERL=1)

I desperately need help!

Solution

Thanks guys for your comments. I fixed it by removing git and installing it “apt-get install git.”

The problem was that the Bitnami-LAMP VM came with a pre-built-git that, I guess, wasn’t built with PERL. I checked my PERL version and is fine. Anyways, all is good.

Answered By – mjquito

This Answer collected from stackoverflow, is licensed under cc by-sa 2.5 , cc by-sa 3.0 and cc by-sa 4.0

Leave a Reply

(*) Required, Your email will not be published