Firebase app check on iOS get crash on build

Issue

Every think were working very well until I added package firebase_app_check: ^0.0.3

The app gets crashes on the building project to run on iOS, on Android it works very well.

Andoird app can connect to firebase but, iOS cant do that becouse the request does not authnticated.

Flutter :2.5.2

Verbose

CocoaPods' output:
↳
      Preparing

    Analyzing dependencies

    Inspecting targets to integrate
      Using `ARCHS` setting to build architectures of target `Pods-Runner`: (``)

    Finding Podfile changes
      A firebase_app_check
      - Flutter
      - cloud_firestore
      - cloud_functions


 Fetching external sources
    -> Fetching podspec for `Flutter` from `Flutter`
    -> Fetching podspec for `cloud_firestore` from `.symlinks/plugins/cloud_firestore/ios`
    cloud_firestore: Using Firebase SDK version '8.9.0' defined in 'firebase_core'
    -> Fetching podspec for `cloud_functions` from `.symlinks/plugins/cloud_functions/ios`


 Resolving dependencies of `Podfile`
      CDN: trunk Relative path: CocoaPods-version.yml exists! Returning local because checking is only performed in repo update
      CDN: trunk Relative path: all_pods_versions_0_3_5.txt exists! Returning local because checking is only performed in repo update
      CDN: trunk Relative path: Specs/0/3/5/Firebase/8.9.1/Firebase.podspec.json exists! Returning local because checking is only performed in repo update
      CDN: trunk Relative path: Specs/0/3/5/Firebase/8.9.0/Firebase.podspec.json


[!] CocoaPods could not find compatible versions for pod "Firebase/AppCheck":
      In Podfile:
        firebase_app_check (from `.symlinks/plugins/firebase_app_check/ios`) was resolved to 0.0.3, which depends on
          Firebase/AppCheck (= 8.9.0)

    Specs satisfying the `Firebase/AppCheck (= 8.9.0)` dependency were found, but they required a higher minimum deployment target.




.rb:52:in `run'
    /Library/Ruby/Gems/2.6.0/gems/claide-1.0.3/lib/claide/command.rb:334:in `run'
    /Library/Ruby/Gems/2.6.0/gems/cocoapods-1.11.2/lib/cocoapods/command.rb:52:in `run'
    /Library/Ruby/Gems/2.6.0/gems/cocoapods-1.11.2/bin/pod:55:in `<top (required)>'
    /usr/local/bin/pod:23:in `load'
    /usr/local/bin/pod:23:in `<main>'

Solution

Add platform :ios, '11.0' to the Podfile.

AppCheck requires iOS 11.

Answered By – Paul Beusterien

This Answer collected from stackoverflow, is licensed under cc by-sa 2.5 , cc by-sa 3.0 and cc by-sa 4.0

Leave a Reply

(*) Required, Your email will not be published