[Fixed] Is there a compatibility list for Angular / Angular-CLI and Node.js?

Issue

I periodically run into the problem, having to spin up old Angular projects with deprecated dependencies of Angular.

Because I unsually run the latest Node.js version (at least lates LTS version) I often had the problem, that I wasn’t able to get the old projects running.
I solved this by using a node version manager, but still I often have the problem that I’m not sure what is the best Node.js version to use for Angular Version X.

Sadly the official release notes handle this topic shabbily and are not a true help, especially if you like to know as of which Angular Version you can’t use a specific Node.js version anymore…

Is there a complete compatibility list to check which Angular version is compatible with which Node.js version?

Solution

|Angular CLI|       Angular      |            NodeJS            |TypeScript |
|-----------|--------------------|------------------------------|-----------|
|-          |2.x                 |6.0.x or later minor          |2.0.x      |
|1.0.6      |4.x                 |6.9.x or later minor          |2.2.x      |
|1.1.3      |4.x                 |6.9.x or later minor          |2.3.x      |
|1.2.7      |4.x                 |6.9.x or later minor          |2.3.x      |
|1.3.2      |4.2.x or later minor|6.9.x or later minor          |2.4.x      |
|1.4.10     |4.2.x or later minor|6.9.x/8.9.x or later minor    |2.4.x      |
|(1.5.6)    |5.0.x               |6.9.x/8.9.x or later minor    |2.4.x      |
|1.5.6      |5.1.x               |6.9.x/8.9.x or later minor    |2.5.x      |
|1.6.7      |5.2.x or later minor|6.9.x/8.9.x or later minor    |2.5.x      |
|1.7.4      |5.2.x or later minor|6.9.x/8.9.x or later minor    |2.5.x      |
|6.0.8      |6.0.x               |8.9.x or later minor          |2.7.x      |
|6.1.5      |6.1.x               |8.9.x or later minor          |2.7.x      |
|6.2.9      |6.1.x               |8.9.x or later minor          |2.9.x      |
|7.0.7      |7.0.x               |8.9.x/10.9.x or later minor   |3.1.x      |
|7.1.4      |7.1.x               |8.9.x/10.9.x or later minor   |3.1.x      |
|7.2.4      |7.2.x               |8.9.x/10.9.x or later minor   |3.2.x      |
|7.3.9      |7.2.x               |8.9.x/10.9.x or later minor   |3.2.x      |
|8.0.6      |8.0.x               |10.9.x or later minor         |3.4.x      |
|8.1.3      |8.1.x               |10.9.x or later minor         |3.4.x      |
|8.2.2      |8.2.x               |10.9.x or later minor         |3.4.x      |
|8.3.25     |8.2.x               |10.9.x or later minor         |3.5.x      |
|9.0.7      |9.0.7               |10.13.x/12.11.x or later minor|3.6.x/3.7.x|
|9.x        |9.x                 |10.13.x/12.11.x or later minor|3.6.x-3.8.x|
|10.x       |10.x                |10.13.x/12.11.x or later minor|3.9.x      |
|10.1.x     |10.1.x              |10.13.x/12.11.x or later minor|3.9.x/4.0.x|
|10.2.x     |10.2.x              |10.13.x/12.11.x or later minor|3.9.x/4.0.x|
|11.0.7     |11.0.x              |10.13.x/12.11.x or later minor|4.0.x      |
|11.1.x     |11.1.x              |10.13.x/12.11.x or later minor|4.0.x/4.1.x|
|11.2.x     |11.2.x              |10.13.x/12.11.x or later minor|4.0.x/4.1.x|
|12.0.x     |12.0.x              |12.13.x/14.15.x or later minor|4.2.x      |

ref: https://gist.github.com/LayZeeDK/c822cc812f75bb07b7c55d07ba2719b3

Leave a Reply

(*) Required, Your email will not be published