One of the reasons for this error is your flutter app requires flutter_svg v0.18.0 or greater version.
Add following dependency to pubspec.yaml
flutter_svg : ^0.18.0
Please note that if you are using flutter_html <= 1.0.0 versions, you can’t install flutter_svg v0.17 + versions. So you may need to change flutter_html dependency version too