Flutter Error: Your project requires a higher compileSdkVersion

Issue

when I clone and run the project, it shows: Your project requires a higher compileSdkVersion.So I did what it said, which to change:

android {                                                                                                                    │
│   compileSdkVersion 31                                                                                                       │
│ }     

in android\app\build.gradle. But then it show another error: failed
to install
D:\programming\Flutter_Projects\mi_card_flutter\build\app\outputs\flutter-apk\app.apk:
Failure [INSTALL_FAILED_INSUFFICIENT_STORAGE] Error launching
application on AOSP on IA Emulator.

Solution

INSTALL_FAILED_INSUFFICIENT_STORAGE error means that there is no enough space to install the app, try to clean some space by uninstalling unwanted apps or removing unwanted files from the physical device or the emulator you are trying to run on it.

Answered By – Moaz El-sawaf

This Answer collected from stackoverflow, is licensed under cc by-sa 2.5 , cc by-sa 3.0 and cc by-sa 4.0

Leave a Reply

(*) Required, Your email will not be published