Getting compileSdkVersion is not specified. Please add it to build.gradle

Issue

Getting this error while building apk

A problem occurred configuring project ‘:app’.

com.android.builder.errors.EvalIssueException: compileSdkVersion is not specified. Please add it to build.gradle

In build.gradle already added
compileSdkVersion cordovaConfig.COMPILE_SDK_VERSION

Also in config.xml file added

Can anyone help me what’s the issue

Ionic Info

Ionic:

Ionic CLI : 5.4.16 (C:\Users\anshi\AppData\Roaming\npm\node_modules\ionic)
Ionic Framework : @ionic/angular 5.9.4
@angular-devkit/build-angular : 12.1.4
@angular-devkit/schematics : 12.2.18
@angular/cli : 12.2.18
@ionic/angular-toolkit : 4.0.0

Cordova:

Cordova CLI : 11.0.0
Cordova Platforms : android 11.0.0
Cordova Plugins : cordova-plugin-ionic-keyboard 2.2.0, cordova-plugin-ionic-webview 4.2.1, (and 23 other plugins)

Utility:

cordova-res : 0.15.4
native-run (update available: 1.7.1) : 1.5.0

System:

Android SDK Tools : 26.1.1 (C:\Users\username\AppData\Local\Android\Sdk)
NodeJS : v16.13.0 (C:\Program Files\nodejs\node.exe)
npm : 6.14.18
OS : Windows 10

Solution

Install module

npm i @ionic/cordova-builders

Answered By – Albin C S

This Answer collected from stackoverflow, is licensed under cc by-sa 2.5 , cc by-sa 3.0 and cc by-sa 4.0

Leave a Reply

(*) Required, Your email will not be published