Git Bash: Microsoft Visual C++ 14.0 is required, but I already have it installed

Issue

I am using git to clone https://github.com/rkern/line_profiler.git on Windows 10. It is erroring out with this error but I have this installed (see image below):

error: Microsoft Visual C++ 14.0 is required. Get it with “Microsoft Visual C++ Build Tools”: https://visualstudio.microsoft.com/downloads/

This is the command I am using:

git clone https://github.com/rkern/line_profiler.git
find line_profiler -name '*.pyx' -exec cython {} \;
cd line_profiler
pip install . --user

enter image description here

Solution

You don’t have any Visual C++, you only have Redistributable packages. They install run-time libraries that are used to run applications written with VC. But you need Visual C++ compiler! Install Build Tools.

See https://stackoverflow.com/search?q=%5Bpip%5D+Microsoft+Visual+C%2B%2B+14.0+is+required

Answered By – phd

This Answer collected from stackoverflow, is licensed under cc by-sa 2.5 , cc by-sa 3.0 and cc by-sa 4.0

Leave a Reply

(*) Required, Your email will not be published