How to install Poppler on Windows?

Issue

The most recent version of ScraperWiki depends on Poppler (or so the GitHub says). Unfortunately, it only specifies how to get it on macOS and Linux, not Windows.

A quick googling turned up nothing too promising. Does anyone know how to get Poppler on Windows for ScraperWiki?

Solution

Poppler Windows binaries are available from ftp://ftp.gnome.org/Public/GNOME/binaries/win32/dependencies/ — but note that those aren’t quite up-to-date.

If you’re looking for Python (2.7) bindings (as this question’s tag suggests), I requested them in the past via this bug report. A couple of people apparently managed to produce something, but I haven’t checked those out yet.

As for a more recent (python bindings unrelated) poppler Windows binaries Google result, see http://blog.alivate.com.au/poppler-windows/

Finally, there’s the brand-new (and currently very frequently updated) PyGObject all-in-one installer (mainly aiming to provide PyGObject-instrospected Gtk+3 Python bindings etc. for Windows), so if that’s what you’re looking for, go to http://sourceforge.net/projects/pygobjectwin32/files/?source=navbar

Answered By – Bernhard Reiter

This Answer collected from stackoverflow, is licensed under cc by-sa 2.5 , cc by-sa 3.0 and cc by-sa 4.0

Leave a Reply

(*) Required, Your email will not be published