'NestMicroservice' incorrectly implements interface 'INestMicroservice'

Issue

error TS2420: Class ‘NestMicroservice’ incorrectly implements interface ‘INestMicroservice’.
Property ‘listenAsync’ is missing in type ‘NestMicroservice’ but required in type ‘INestMicroservice’.

Solution

Simply ensure you install the same version of the current @nestjs/core.
Ex: If you’re currently on NestJS Version 8 (@nestjs/core -> 8.4.7)
pnpm i @nestjs/[email protected]

Answered By – Vixson

This Answer collected from stackoverflow, is licensed under cc by-sa 2.5 , cc by-sa 3.0 and cc by-sa 4.0

Leave a Reply

(*) Required, Your email will not be published