The plugin admob_flutter uses a deprecated version of the Android embedding

Issue

when i put admob_flutter: ^2.0.0-nullsafety.1 in pubspec, and type on cmd flutter pub get this error occurs!

The plugin admob_flutter uses a deprecated version of the Android embedding.
To avoid unexpected runtime failures, or future build failures, try to see if this plugin supports the Android V2 embedding. Otherwise, consider removing it since a future release of
Flutter will remove these deprecated APIs.

Solution

It’s for latest flutter updates. so you can’t do anything. Please use other package or wait till fix the problem by package developer because this error is produced after flutter version 2.5.

Answered By – Tushar Moradiya

This Answer collected from stackoverflow, is licensed under cc by-sa 2.5 , cc by-sa 3.0 and cc by-sa 4.0

Leave a Reply

(*) Required, Your email will not be published