When installing Pipfile there is a collision of dependency version of werkzeug, werkzeug<1.0 from zappa, werkzeug>2.0 from flask


When installing the Pipfile i’m getting the error ‘ERROR: Could not find a version that matches werkzeug<1.0,>=2.0’

There are incompatible versions in the resolved dependencies:
werkzeug<1.0 (from zappa==0.51.0)
werkzeug>=2.0 (from flask==2.0.1)

MY Pipfile contains (among other stuff):

flask = "*"
werkzeug = "*"
zappa = "*"


your zappa version is 0.51.0 which was released on March 2020 and your flask version is 2.0.1 which was released on May 2021 and their sub dependencies are different.
I fixed the issue by downgrading the flask version by specifying version 1.1.4 in pipfile.
flask = "==1.1.4"

Answered By – PIE.K

This Answer collected from stackoverflow, is licensed under cc by-sa 2.5 , cc by-sa 3.0 and cc by-sa 4.0

Leave a Reply

(*) Required, Your email will not be published